SQL SERVER – How Enable Transparent Database Encryption (TDE) for Database...
Life can teach you interesting lessons and push you beyond the boundary of what we call as a comfort zone. Recently I had a customer who was working on SQL server 2008 R2 and was enabling Mirroring....
View ArticleSQL SERVER – Mirroring Error 1412 – The remote copy of database has not been...
With mirroring gone as deprecated feature, I have tried to keep away from exploring into what has been happening in this space. But what can I do when customers still use them? The challenges for...
View ArticleSQL SERVER – Installation Error – File Format is Not Valid
The reason I love consulting is because I get to see many flavors of the problems. This new avatar for me is pushing the limits to how I keep learning technologies. My recent interaction with client...
View ArticleSQL SERVER – Setup closed with exit code: 0x80004005
Recently I was trying to help one of my client to install Service Pack 3 for SQL Server 2008 R2 instance. Nothing was coming up when we were hitting setup.exe. I looked into my own blog and found SQL...
View ArticleSQL SERVER – Exception Code c0000005 While Starting SQL Service
Sometimes I get to see very weird errors by my blog readers and I have no clue about it. Getting a picture about what has happened in the past gives some hint about the solution. This post is a result...
View ArticleSQL SERVER – Unable to start SQL Server Agent – Failed to initialize SQL...
My friend was researching with SQL Agent parameters and after sometime he called me and told that he is not able to start SQL Agent service. Here was the error in SSMS Text is below: TITLE: Microsoft...
View ArticleSQL SERVER – AlwaysOn Availability Group Stuck in Resolving State For Long time
This is one of the common issues which I heard from my clients using SQL Server and they don’t know why it happens. What is resolving state in SQL Server AlwaysOn? When there is an availability group,...
View ArticleSQL SERVER – Starting Up Database – Why Multiple Times in Errorlog?
Fixing error messages is something which keeps me energized because there is something challenging that is put in front of me. I know these can be frustrating times working on errors, but they also...
View ArticleSQL SERVER – FIX: Error: 18456, Severity: 14, State: 6. Login failed for user
One of the blog which I wrote earlier was also on Login failed for user with state 58. After reading that blog, one of the blog reader contacted me and told that she is getting state 6. I thought this...
View ArticleSQL SERVER – FIX: Error: 18456, Severity: 14, State: 58. Login failed for user
One of the most common and searched SQL Server failure is around “Logins”. Login failed for user has always been tricky and interesting to troubleshoot. I don’t think there is a silver bullet to easily...
View ArticleSQL SERVER – Huge Transaction log (LDF) for Database in Availability Group
One of my blog readers posted on Facebook: Hi Pinal, We are using AlwaysOn availability group for our production database. The database is fairly large in size as its around 260 GB. The database...
View ArticleSQL SERVER – Install Error – The /UIMode setting cannot be used in...
Doing repetitive tasks is something everyone hates. I am sure many of us have resorted to ingenious techniques to figure out doing the task efficiently. There is no standard tool or technique that...
View ArticleInterview Question of the Week #056 – How to fix Installation Failure – Rule...
Sometimes in the interviews I observe that users are able to answer all the theoretical questions correct but when it is about doing practical they fail. A while ago, when I was helping a large...
View ArticleSQL SERVER – Script level upgrade for database ‘master’ failed because...
I do apply patches to my SQL instances as and when they are released by Microsoft. This is important because I always feel keeping the bits uptodate is essential because I don’t want to get infected as...
View ArticleSQL SERVER – 2016 Error Reasons: Msg 10778, Level 16 Foreign key...
When I was writing the blog SQL SERVER 2016 – InMemory OLTP support for Foreign Key, it felt like a great addition to SQL Server. I felt there must be something that I might be missing as the obvious....
View ArticleSQL SERVER – Fixing Annoying Network Binding Order Error – Notes from the...
[Note from Pinal]: In this episode of the Notes from the Field series database expert Ryan Adams explains a very critical error user receive when binding network error. Ryan is one guy who spends more...
View ArticleSQL SERVER – Add failover cluster node fails with “number of cluster nodes...
A lot of my blog readers contact me via comments and I try my best to reply to all of them. Sometimes issue is so interesting that I ask them to contact via email. This blog is result of such an...
View ArticleSQL SERVER – Timeout expired. The timeout period elapsed prior to completion...
Some errors when encountered take most of us for a spin. In this category the error related to “Timeout” surely falls. If you are a web developer and receive the same there are a hundred combinations...
View ArticleSQL SERVER – FIX: Msg 4335, Level 16, State 1 – The specified STOPAT time is...
While trying to prepare for a demo, I ran into some interesting error. When I searched for error on the internet, there were not many clear answers so I thought of sharing on my blog. Actually, my demo...
View ArticleSQL SERVER – System.IO.FileNotFoundException: Could not load file or assembly
In a recent R&D operation, I was trying to use some SQLCLR assembly as part of the installation process. It was not easy but it got me into a mess that I thought was worth debugging. One of the...
View Article